
TECHNICAL pApEr

Migrating from  
CorelDRAW to Illustrator  
A Technical Resource
Switching tools in a work environment is not a trivial task even when the overall goal 
is a more efficient and beneficial workflow. But there are many benefits in moving from 
CorelDRAW® to Adobe® Illustrator® CS2, including better integration with Adobe 
Creative Suite components like Adobe Photoshop®, Adobe InDesign®, Adobe GoLive®, 
and Adobe Acrobat®. In addition, support for open standards like OpenType®, PDF/X, 
SVG-t, CSS, and XMP help ensure that Illustrator is a perfect fit in any workflow.

When migrating from CorelDRAW to Illustrator, one of the main concerns is convert-
ing an existing library containing years of legacy CorelDRAW files so that you can use 
them in an Illustrator workflow. This document is a technical resource for using legacy 
CorelDRAW content in Illustrator. For detailed information on the new features in 
Illustrator CS2, see the Discover Adobe Illustrator CS2 guide on the Adobe website at 
www.adobe.com/Illustrator.

Note: CorelDRAW X3 is a suite of graphics applications that includes CorelDRAW, Corel 
PowerTRACE, Corel PHOTO-PAINT, CorelRAVE and Corel CAPTURE. Illustrator CS2 
includes similar functionality to that found in CorelDRAW and PowerTRACE, Photoshop is 
similar to Corel PHOTO-PAINT, and Flash® is similar to CorelRAVE. For more information, 
see Adobe Creative Suite CS2 on the Adobe website at www.adobe.com/creativesuite.

Importing CorelDRAW files, and working with Illustrator files
When moving files from CorelDRAW to Illustrator, the file format affects how your 
files appear in Illustrator. In this section, we will explore several file formats you can 
use when moving files from CorelDRAW to Illustrator, and the benefits of each. Once 
you’ve opened your legacy CorelDRAW files in Illustrator, you can save and export 
them in a variety of formats.

What is the best way to import my legacy CorelDRAW files into Illustrator?
It depends on the type of illustration and whether you plan to edit the text in the file. 
Each method has its pros and cons, especially in the way text and multiple pages are 
affected. For a side-by-side comparison of formats, see the table on page 2.

•	 CorelDRAW	10		Illustrator can open native CorelDRAW 10 files directly. If you use 
CorelDRAW X3, you must first save your files in CorelDRAW 10 format. To save a 
file in CorelDRAW 10 format, choose File > Save As and then choose Version 10.0 
from the Version pop-up menu. Click Save.

•		 Encapsulated	PostScript		Illustrator can open Encapsulated PostScript (EPS) files 
created from CorelDRAW. To export a CorelDRAW file as an EPS file, choose File 
> Export and choose Encapsulated PostScript from the Save As Type pop-up menu. 
Click Export.

•		 PDF		To save a CorelDRAW file as an Adobe PDF file, choose File > Publish to PDF. 
Click Save.

•		 Illustrator	CS2		CorelDRAW can save a native Illustrator file, which you can open in 
Illustrator CS2. With your file open in CorelDRAW, choose File > Save As and choose 
Adobe Illustrator from the Save As Type pop-up menu. Click Save and choose Adobe 
Illustrator CS2 from the Compatibility pop-up menu. Click OK.
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FILE  
AT TRIBuTE

FILE SAvED AS  
CORELDRAW 10 (.CDR)

FILE ExpORTED AS  
EpS (.EpS)

FILE puBLIShED AS  
pDF (.pDF)

FILE SAvED OR ExpORTED AS  
ILLuSTRATOR CS2 (.AI)

Text Text remains unbroken and editable, but 
kerning information is not retained and 
text may reflow.

Text appearance is maintained, but text 
is broken into separate text strings and is 
less editable.

Text appearance is maintained, but text 
is broken into separate text strings and is 
less editable.

Text appearance is maintained but all 
characters are converted to outlines, 
rendering text uneditable.

Multiple 
pages

Only the first page of the document is 
imported. Multiple pages must be saved 
and opened individually.

Each page is exported as a separate EPS 
file, which can be opened as individual 
documents in Illustrator.

Illustrator presents you with a dialog box 
with previews so that you may choose 
which page you want to open.

CorelDRAW exports only the active page.

Fountain fills 
(gradients)

Linear and radial gradients are main-
tained and are editable. Other gradient 
types are rasterized.

All gradient types are rasterized and 
maintain their appearance. The number 
of steps used in the gradient may not be 
enough for quality reproduction.

Linear and radial gradients are converted 
to non-native Illustrator objects. All 
other gradient types are expanded and 
maintain their appearance.

Linear and radial gradients are main-
tained and are editable. Other gradient 
types are rasterized.

Blends Blends are maintained and converted to 
Illustrator Live Blends.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Blends maintain their appearance but 
are expanded into individual objects for 
each step in the blend.

Colors All process colors used in the file are 
imported and defined as global process 
color swatches. Spot colors are lost and 
objects originally filled with spot colors 
may be filled with black.

All swatches and spot colors are  
imported and preserved.

Spot color swatches and colors are 
imported and preserved.

Spot color swatches and process colors 
are imported and preserved.

When converting files from CorelDRAW to Illustrator, the attributes that are most important to you will determine 
which file format will work best.

When I open a file from CorelDRAW, I am sometimes presented with a Convert Color Mode dialog 
box. What does this mean?
Similar to the artboard in Photoshop, Illustrator’s artboard uses a single color mode. If you open 
a document that contains both CMYK and RGB data, Illustrator asks you what color mode you 
want to work in, and converts all colors to match the chosen color space. To manually change a 
document’s color space in Illustrator, choose File > Document Color Space. The settings specified in  
Illustrator’s Color Settings dialog box (Edit > Color Settings) determine how colors are converted.

When you open a document that contains both CMYK and RGB elements, Illustrator asks you to choose a single  
color mode.

Does Illustrator have a prepare For Service Bureau feature like CorelDRAW?
While Illustrator doesn’t have a built-in feature that automatically collects all linked images  
used in a document, it does include a script that performs this function. In Mac OS, this script  
is in the Adobe Illustrator CS2/Scripting/Sample Scripts/AppleScript/Collect for Output folder. 
In Windows, the script is in the Adobe Illustrator CS2/Scripting/Sample Scripts/Visual Basic/ 
Collect for Output folder. To make the script available in the Scripts menu, copy it into the 
Adobe Illustrator CS2/Presets/Scripts folder and then restart Illustrator.

In addition, you can see a list of all placed images in a document by looking at the Links palette, 
(Window > Links), and you can see all of the fonts used in a document by looking at the Find 
Font dialog box (Type > Find Font).

In CorelDRAW, I am able to publish a document as pDF. how do I create a pDF from Illustrator?
Since Adobe PDF is a file format that can be round-trip edited in Illustrator, you save PDF files 
from Illustrator rather than publish them as you would from CorelDRAW. To create a PDF file 
from Illustrator, choose File > Save As and choose Adobe PDF from the Format pop-up menu, 
and then click Save. In the Save Adobe PDF dialog box, specify options for the resulting PDF 
file. For more information, see the PDF file creation section of the Print Resource Center on the 
Adobe website at www.adobe.com/studio/print/designer.html#pdfcreation.
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how do I export a GIF or a JpEG file from Illustrator?
To export GIF or JPEG images for use on the web, choose File > Save For Web. In the Save For 
Web dialog box, you can preview your art in a multitude of web file formats including GIF, JPEG, 
PNG, WBMP, SWF, and SVG. Select the web-friendly file format you want, customize the com-
pression settings as desired, and click Save.

how do I create Flash (SWF) files from Illustrator?
There are two ways to export Illustrator files to SWF files: Choose File > Export and then choose 
Macromedia Flash (.SWF) from the Format pop-up menu, or use the Save For Web feature. The 
export function offers extended functionality, such as the ability to set background layers and to 
automatically animate blends.

Working with text
Illustrator contains a Unicode-compliant text engine that provides full support for OpenType 
fonts as well as optical kerning, optical margin alignment, every-line composing, and multilin-
gual hyphenation and spell checking. The following section covers issues that you might encoun-
ter when importing and working with text.

Does Illustrator maintain kerning or text styling when importing files from CorelDRAW?
Editable kerning values are not retained when you open CorelDRAW files in Illustrator.  
However, you can maintain the appearance of kerned text (but will lose the ability to edit it)  
by exporting files from CorelDRAW as EPS or PDF files. For more information, see the table  
on page 2.

Does Illustrator support unicode text?
Yes, the text engine in Illustrator is Unicode-compliant. For more information on the Unicode 
standard, see www.unicode.org.

Does Illustrator support OpenType fonts?
Yes, Illustrator has full support for OpenType fonts. OpenType is an open standard font format 
that is Unicode-based and that supports advanced features like automatic glyph replacement.  
For more information on OpenType fonts, visit the Adobe website at http://studio.adobe.com/us/
type/main.jsp?xhtml=opentype/main.

When I open a pDF or EpS file that wasn’t created in Illustrator, text is broken into individual text 
blocks. Is there any way to avoid this?
No. To preserve kerning and the appearance of text objects, text in imported generic EPS or PDF 
files (that is, an EPS or a PDF created with an application other than Illustrator) is not imported 
as a single string of editable text.

To combine multiple text objects into a single text string, you can use the Selection tool (black 
arrow tool) to select the different type objects, choose Edit > Copy, switch to the Type tool and 
create a new area text object, and then choose Edit > Paste.

Working with objects and colors
There are some differences in how CorelDRAW and Illustrator work with objects and colors. 
This section discusses how to work around these differences.

Where is the place Inside Container function in Illustrator?
Illustrator uses a variety of mask functions to clip objects, unlike CorelDRAW, which has a Place 
Inside Container function. The ability to define layer masks in Illustrator makes it possible to 
have multiple objects clipped by a single object while maintaining layer structure.

• To apply a clipping mask on an object-by-object basis, first draw a shape that you want to use 
as a mask. Place this shape above your artwork in the object stacking order. Select both the 
artwork and the mask shape and choose Object > Clipping Mask > Make. Illustrator groups 
the artwork with the mask. You can use the Direct Selection tool (white arrow tool) to move 
the artwork and the mask independently.

• For more complex objects, and to maintain layer structure, first draw a shape that you want to use 
as a mask. Bring the object to the top level of the layer. In the Layers palette, highlight the layer 
that contains the shape and click the Create/Release Clipping Mask button at the bottom of the 
palette. The path is listed with an underline in the palette and clips all objects within that layer.
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CorelDRAW has a feature called Shaping, which allows me to combine multiple shapes using path 
operations. Does Illustrator have similar capabilities?
Illustrator contains a collection of path-combining functions in the Pathfinder palette. Func-
tions like Add To Shape Area and Subtract From Shape Area are similar to the Weld and Trim 
commands in CorelDRAW. When you choose one of the Shape Modes from the Pathfinder 
palette, the result is a live editable effect. To make the effect permanent, you can select the object 
and click the Expand button in the Pathfinder palette.

The Pathfinder palette contains many functions for combining paths, making it easy to combine primitive vector 
shapes into more complex ones.

how do I select through objects in Illustrator?
In Illustrator, you can select objects that are beneath other objects by choosing Select > Next Object 
Below. You can also access this command by right-clicking (Windows) or Ctrl-clicking (Mac OS).

You might find it easier to select objects when the Object Selection By Path Only setting in the 
General preferences panel is selected. With this setting turned on, you can select objects only by 
clicking on their path—as opposed to clicking anywhere within the fill area of the object.

Does Illustrator have a clone command, like CorelDRAW does?
Yes. To clone a selection in Illustrator:

1.  Choose Edit > Copy (Command+C in Mac OS, or Ctrl+C in Windows).

2.   Choose Edit > Paste In Front (Command+F in Mac OS, or Ctrl+F in Windows), or Edit > 
Paste In Back (Command+B in Mac OS, or Ctrl+B in Windows).

You can also hold the Option key (Mac OS) or Alt key (Windows) when you move or transform 
an object to leave a copy behind.

Can Illustrator create 3D objects?
Yes. To apply a 3D effect in Illustrator, make a selection and choose Effect > 3D, and then choose 
Extrude & Bevel, Revolve, or Rotate.

Does Illustrator contain the newer pantone color libraries?
Yes, Illustrator contains the updated Pantone libraries that were created in 2000. Choose  
Window > Swatch Libraries to access any of the 10 Pantone libraries included with Illustrator:  
Metallic Coated, Pastel Coated, Pastel Uncoated, Process Coated, Process Uncoated, Solid 
Coated, Solid Matte, Solid Uncoated, Solid to Process Coated, and Solid to Process Uncoated.

Can I define a conical or square fountain fill in Illustrator CS2?
No. Illustrator only supports linear and radial gradients.

Does Illustrator have a search and replace feature, like CorelDRAW?
Illustrator contains a text-based search-and-replace feature (Edit > Find), but does not have a 
graphic search-and-replace function like CorelDRAW.

how do I select multiple objects with the same attributes in Illustrator?
Illustrator has a Select menu that allows you to select a single object and then select all other objects 
that either contain a similar fill or stroke color, stroke weight, or other similar attributes. In addition, 
Illustrator contains a Magic Wand tool that allows you to select objects that have a similar attributes, 
such as fill color, stroke color, stroke weight, opacity, or blending mode with a single click.

Double-clicking on the Magic Wand tool brings up the Magic Wand palette.
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how do I align or distribute objects in Illustrator?
Illustrator has an Align palette (Window > Align) that contains functions for aligning objects to 
each other or to the artboard, and for distributing objects evenly. Select the objects you want to 
align, and then select one of the icons in the Align palette. These icons also appear in the Control 
palette when multiple objects are selected.

Choosing the Align To Artboard setting in the palette menu allows you align objects to the page.

General document settings
Both Illustrator and CorelDRAW support a wide range of features that can be used to be more 
productive, to express your creativity, and to push the boundaries of design. This section 
explores general application use and offers guidance on how to get the most out of Illustrator.

how do I add pages to my document in Illustrator?
Unlike CorelDRAW, Illustrator follows a single-page-per-document model. However, you can use 
the Page Tiling feature in Illustrator to simulate multiple pages in a single document (see Illustrator 
Help for information on how to set up page tiles). Alternatively, you can use layers to simulate 
multiple page layouts.

how can I edit photographic content in Illustrator?
While Illustrator can place photographic (raster) content, it cannot edit such files. To edit  
photographic content, you need a raster-based application like Photoshop.

how can I add barcodes in Illustrator?
Illustrator does not have the ability to make barcodes. That functionality is only available 
through third-party plugins.

Can I add rollovers in Illustrator as I can in CorelDRAW?
No. Illustrator does not have the ability to create rollovers. However, Adobe ImageReady®, which 
is a component of Photoshop, does. Alternatively, you can use Fireworks® and Flash® for web 
rollovers, and Adobe InDesign® for creating rollovers in interactive PDF files.

how do I create guides in Illustrator?
To create guides in Illustrator, drag them out from the horizontal or vertical rulers (choose View 
> Show Rulers to turn on the rulers). Alternatively, you can convert any vector object into a guide 
by choosing View > Guides > Convert To Guide. In Illustrator, there is no dedicated layer for 
guides. Guides are added to the layers that they are drawn on.

It should be noted that guides are locked by default in Illustrator. To edit guides once they are 
already created, choose View > Guides > Lock Guides.

Does Illustrator have a powerTRACE function to convert bitmap images to vectors?
Illustrator CS2 has a powerful new feature called Live Trace, which enables you to convert  
bitmapped images into vector paths. For detailed information on the Live Trace feature, see 
Creating Vector Content Using Live Trace on the Adobe website at www.adobe.com/products/
illustrator/pdfs/creating_vector_content.pdf.

I’ve heard that transparency effects don’t always print reliably. Do these similar effects print  
reliably from Illustrator?
For transparency effects (like blend modes or soft drop shadows) to print to a PostScript device, 
the transparency must be flattened. This process happens automatically when you print your file, 
save it in EPS format, or export it to any format that doesn’t support transparency. For informa-
tion on how transparency flattening works, see The Designer’s Guide to Transparency on the 
Adobe website at www.adobe.com/products/creativesuite/pdfs/dgt.pdf.

dator8.info

http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf
http://www.adobe.com/products/creativesuite/pdfs/dgt.pdf
http://www.dator8.info


FOR MORE INFORMATION

For	a	comprehensive	overview	of		
Adobe	Illustrator	CS2,	visit	the	Adobe		
website	at	www.adobe.com/products/	
illustrator/main.html.

Adobe	Systems	Incorporated
345	Park	Avenue,	San	Jose,	CA	95110-2704	USA	
www.adobe.com

Adobe,	the	Adobe	logo,	Illustrator,	Photoshop,	Acrobat,	GoLive,		
ImageReady,	InDesign,	Fireworks	and	Flash	are	either	registered	
trademarks	or	trademarks	of	Adobe	Systems	Incorporated	in	the	
United	States	and/or	other	countries.	Mac	OS	is	a	trademark	of	
Apple	Computer,	Inc.,	registered	in	the	United	States	and	other	
countries.	Microsoft,	Windows,	and	OpenType	are	either	registered	
trademarks	or	trademarks	of	Microsoft	Corporation	in	the	United	
States	and/or	other	countries.	All	other	trademarks	are	the	property		
of	their	respective	owners.	

©	2006	Adobe	Systems	Incorporated.	All	rights	reserved.

I have heard that Illustrator supports metadata. What does that mean?
Metadata is information that describes the content of a document, which can then 
be used in searches. Illustrator has full support for the Extensible Metadata Platform 
(XMP) standard for storing metadata, and such information can be added to a file 
either using the File Info dialog box or Adobe Bridge. For more information on the 
XMP Metadata standards, please visit the Adobe website at www.adobe.com/products/
xmp/main.html.

What measurement systems does Illustrator support?
Illustrator supports points, picas, inches, millimeters, centimeters, and pixels.

Terminology differences
Illustrator and CorelDRAW share many similar functions, but the terminology used for 
tools, menu commands, or functions differs in some cases.

CORELDRAW ILLuSTRATOR

Dockers Palettes

PowerTRACE Live Trace

Fountain fill Gradient fill

Import Place

Export for Office Save for Microsoft Office

Wireframe Outline

Enhanced with Overprints Overprint preview

Dynamic Guides Smart guides

Shaping Pathfinder

Resources
For additional information on the topics discussed in this document, see the  
following documents:

Discover Adobe Illustrator CS2 (www.adobe.com/products/illustrator/main.html)

Creating vector content using Live Trace  
(www.adobe.com/products/illustrator/pdfs/creating_vector_content.pdf)

Working with type in Adobe Illustrator CS2  
(www.adobe.com/products/illustrator/pdfs/Text_in_AICS2.pdf)

Extensible Metadata Platform (XMP) (www.adobe.com/products/xmp/main.html)

Support for OpenType fonts  
(http://studio.adobe.com/us/type/main.jsp?xhtml=opentype/main)

The Designer’s Guide to Transparency  
(www.adobe.com/products/creativesuite/pdfs/dgt.pdf)
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